[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110524065715.GB12816@elte.hu>
Date: Tue, 24 May 2011 08:57:15 +0200
From: Ingo Molnar <mingo@...e.hu>
To: Joe Perches <joe@...ches.com>
Cc: Eric Dumazet <eric.dumazet@...il.com>,
David Miller <davem@...emloft.net>, akpm@...ux-foundation.org,
netdev@...r.kernel.org, drosenberg@...curity.com,
a.p.zijlstra@...llo.nl, eparis@...isplace.org,
eugeneteo@...nel.org, jmorris@...ei.org, kees.cook@...onical.com,
tgraf@...radead.org
Subject: Re: [patch 1/1] net: convert %p usage to %pK
* Joe Perches <joe@...ches.com> wrote:
> Maybe for clarity it'd be better to use a switch/case
> or something like:
>
> if (kptr_restrict == 0)
> return ptr;
> if (ptr_restrict == 1 &&
> has_capability_noaudit(current, CAP_SYSLOG))
> return ptr;
> return NULL;
While not breaking that line really - so something like:
if (kptr_restrict == 0)
return ptr;
if (kptr_restrict == 1 && has_capability_noaudit(current, CAP_SYSLOG))
return ptr;
return NULL;
Thanks,
Ingo
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists