lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 14 Jun 2011 07:00:28 -0700
From:	Joe Perches <joe@...ches.com>
To:	Geert Uytterhoeven <geert@...ux-m68k.org>
Cc:	netdev@...r.kernel.org,
	Arnaldo Carvalho de Melo <acme@...stprotocols.net>,
	Jay Cliburn <jcliburn@...il.com>,
	Chris Snook <chris.snook@...il.com>,
	Jie Yang <jie.yang@...eros.com>,
	Sathya Perla <sathya.perla@...lex.com>,
	Subbu Seetharaman <subbu.seetharaman@...lex.com>,
	Ajit Khaparde <ajit.khaparde@...lex.com>,
	Rasesh Mody <rmody@...cade.com>,
	Debashis Dutt <ddutt@...cade.com>,
	Sjur Braendeland <sjur.brandeland@...ricsson.com>,
	Divy Le Ray <divy@...lsio.com>,
	Breno Leitao <leitao@...ux.vnet.ibm.com>,
	Amit Kumar Salecha <amit.salecha@...gic.com>,
	Ron Mercer <ron.mercer@...gic.com>, linux-driver@...gic.com,
	Anirban Chakraborty <anirban.chakraborty@...gic.com>,
	Jon Mason <jdmason@...zu.us>,
	Solarflare linux maintainers <linux-net-drivers@...arflare.com>,
	Steve Hodgson <shodgson@...arflare.com>,
	Ben Hutchings <bhutchings@...arflare.com>,
	Daniele Venzano <venza@...wnhat.org>,
	David Dillow <dave@...dillows.org>,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH net-next 2/2] drivers/net: Remove casts of void *

On Tue, 2011-06-14 at 11:21 +0200, Geert Uytterhoeven wrote:
> On Tue, Jun 14, 2011 at 06:02, Joe Perches <joe@...ches.com> wrote:
> > Unnecessary casts of void * clutter the code.
> > --- a/drivers/net/a2065.c
> > +++ b/drivers/net/a2065.c
> > @@ -426,7 +426,7 @@ static irqreturn_t lance_interrupt (int irq, void *dev_id)
> >        volatile struct lance_regs *ll;
> >        int csr0;
> >
> > -       dev = (struct net_device *) dev_id;
> > +       dev = dev_id;
> 
> I think it would look better if you merge this line with the line that
> defines "dev".

I think so too, but I also think it should look like below
and that's something better done in a separate pass, don't
you think?

diff --git a/drivers/net/a2065.c b/drivers/net/a2065.c
index deaa8bc..25ea98a 100644
--- a/drivers/net/a2065.c
+++ b/drivers/net/a2065.c
@@ -421,16 +421,11 @@ static int lance_tx (struct net_device *dev)
 
 static irqreturn_t lance_interrupt (int irq, void *dev_id)
 {
-	struct net_device *dev;
-	struct lance_private *lp;
-	volatile struct lance_regs *ll;
+	struct net_device *dev = dev_id;
+	struct lance_private *lp = netdev_priv(dev);
+	volatile struct lance_regs *ll = lp->ll;
 	int csr0;
 
-	dev = (struct net_device *) dev_id;
-
-	lp = netdev_priv(dev);
-	ll = lp->ll;
-
 	ll->rap = LE_CSR0;		/* LANCE Controller Status */
 	csr0 = ll->rdp;
 


--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists