[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20111107221823.GE1833899@jupiter.n2.diac24.net>
Date: Mon, 7 Nov 2011 23:18:23 +0100
From: David Lamparter <equinox@...c24.net>
To: Stephen Hemminger <shemminger@...tta.com>
Cc: David Lamparter <equinox@...c24.net>,
netdev <netdev@...r.kernel.org>,
Patrick McHardy <kaber@...sh.net>
Subject: Re: [PATCH 1/2] net: vlan: 802.1ad S-VLAN support
On Mon, Nov 07, 2011 at 01:44:01PM -0800, Stephen Hemminger wrote:
> On Sat, 5 Nov 2011 17:54:14 +0100
> David Lamparter <equinox@...c24.net> wrote:
>
> > +#define vlangrp_for_each_dev(i, grp, vlandev) \
> > + for (i = 0; i < VLAN_N_VID * VLAN_N_PROTOCOL; i++) \
> > + if ((vlandev = vlan_group_get_device_pidx(grp, \
> > + i / VLAN_N_VID, i % VLAN_N_VID)))
> > + /* { code here } */
> > +
>
> Please just open code this. Macro's make the code harder
> to parse for humans. There are a few exceptions like.
> LIST_FOREACH_RCU()
That macro is the same kind as LIST_FOREACH_RCU, as its name says, a
"for_each" wrapper. I think it actually makes the code easier to read.
Plus, if the code is there 10 times instead of one, that's 10 times the
chance to break one of the copypastas.
A quick "git grep -i '#define.*for.*each'" indicates that this kind
of macro is quite common with 428 grep results
(e.g. bond_for_each_slave, for_each_sas_task, ...)
-David
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists