[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4EB7FE13.1000501@freescale.com>
Date: Mon, 7 Nov 2011 09:49:39 -0600
From: Scott Wood <scottwood@...escale.com>
To: Zhao Chenhui <chenhui.zhao@...escale.com>
CC: <linuxppc-dev@...ts.ozlabs.org>, <netdev@...r.kernel.org>,
<leoli@...escale.com>
Subject: Re: [PATCH 6/7] fsl_pmc: Add API to enable device as wakeup event
source
On 11/07/2011 05:22 AM, Zhao Chenhui wrote:
> On Fri, Nov 04, 2011 at 04:14:25PM -0500, Scott Wood wrote:
>> On 11/04/2011 07:39 AM, Zhao Chenhui wrote:
>>> + if (enable && !device_may_wakeup(&pdev->dev))
>>> + return -EINVAL;
>>> +
>>> + clk_np = of_parse_phandle(pdev->dev.of_node, "clk-handle", 0);
>>> + if (!clk_np)
>>> + return -EINVAL;
>>> +
>>> + pmcdr_mask = (u32 *)of_get_property(clk_np, "fsl,pmcdr-mask", NULL);
>>> + if (!pmcdr_mask) {
>>> + ret = -EINVAL;
>>> + goto out;
>>> + }
>>> +
>>> + /* clear to enable clock in low power mode */
>>> + if (enable)
>>> + clrbits32(&pmc_regs->pmcdr, *pmcdr_mask);
>>> + else
>>> + setbits32(&pmc_regs->pmcdr, *pmcdr_mask);
>>
>> We should probably initialize PMCDR to all bits set (or at least all
>> ones we know are valid) -- the default should be "not a wakeup source".
>
> I think it should be initialized in u-boot.
I don't see it. If you mean you think this should be added to U-Boot, I
disagree. U-Boot does not use this, and we should not add gratuitous
U-Boot dependencies to Linux -- especially in cases where there are
existing U-Boots in use for relevant boards, that do not have this.
>>> +/**
>>> + * pmc_enable_lossless - enable lossless ethernet in low power mode
>>> + * @enable: True to enable event generation; false to disable
>>> + */
>>> +void pmc_enable_lossless(int enable)
>>> +{
>>> + if (enable && has_lossless)
>>> + setbits32(&pmc_regs->pmcsr, PMCSR_LOSSLESS);
>>> + else
>>> + clrbits32(&pmc_regs->pmcsr, PMCSR_LOSSLESS);
>>> +}
>>> +EXPORT_SYMBOL_GPL(pmc_enable_lossless);
>>> +#endif
>>
>> Won't we overwrite this later?
>>
>> -Scott
>
> Do you have any idea?
Set a flag that the code that enters (deep) sleep can use.
Also, rename function to mpc85xx_pmc_set_lossless_ethernet().
-Scott
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists