[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1321189845.2069.4.camel@Joe-Laptop>
Date: Sun, 13 Nov 2011 05:10:45 -0800
From: Joe Perches <joe@...ches.com>
To: Dmitry Kravkov <dmitry@...adcom.com>
Cc: davem@...emloft.net, netdev@...r.kernel.org,
Eilon Greenstein <eilong@...adcom.com>
Subject: Re: [PATCH v2 net-next 07/12] bnx2x: simplify definition of
RX_SGE_MASK_LEN and use it.
On Sun, 2011-11-13 at 14:47 +0200, Dmitry Kravkov wrote:
> diff --git a/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h b/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h
[]
> @@ -874,8 +874,7 @@ static inline void bnx2x_clear_sge_mask_next_elems(struct bnx2x_fastpath *fp)
> static inline void bnx2x_init_sge_ring_bit_mask(struct bnx2x_fastpath *fp)
> {
> /* Set the mask to all 1-s: it's faster to compare to 0 than to 0xf-s */
> - memset(fp->sge_mask, 0xff,
> - (NUM_RX_SGE >> BIT_VEC64_ELEM_SHIFT)*sizeof(u64));
> + memset(fp->sge_mask, 0xff, RX_SGE_MASK_LEN * sizeof(u64));
drivers/net/ethernet/broadcom/bnx2x/bnx2x.h:
u64 sge_mask[RX_SGE_MASK_LEN];
perhaps this is more readable as:
memset(fp->sge_mask, 0xff, sizeof(fp->sge_mask));
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists