lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Wed, 4 Jan 2012 09:20:45 +0000
From:	Ian Campbell <Ian.Campbell@...rix.com>
To:	Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>
CC:	Ben Hutchings <bhutchings@...arflare.com>,
	Jan Beulich <JBeulich@...e.com>,
	Konrad Rzeszutek Wilk <konrad@...nok.org>,
	"davem@...emloft.net" <davem@...emloft.net>,
	"dmitry.torokhov@...il.com" <dmitry.torokhov@...il.com>,
	"FlorianSchandinat@....de" <FlorianSchandinat@....de>,
	Jeremy Fitzhardinge <jeremy@...p.org>,
	"Jens Axboe" <axboe@...nel.dk>,
	"xen-devel@...ts.xensource.com" <xen-devel@...ts.xensource.com>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	"netdev@...r.kernel.org" <netdev@...r.kernel.org>
Subject: Re: [PATCH, v2] Xen: consolidate and simplify struct xenbus_driver
 instantiation

On Tue, 2012-01-03 at 20:36 +0000, Konrad Rzeszutek Wilk wrote:
> On Thu, Dec 22, 2011 at 08:38:21PM +0000, Ian Campbell wrote:
> > On Thu, 2011-12-22 at 14:44 +0000, Ben Hutchings wrote:
> > > On Thu, 2011-12-22 at 11:57 +0000, Ian Campbell wrote:
> > > > On Thu, 2011-12-22 at 11:51 +0000, Jan Beulich wrote:
> > > > > >>> On 22.12.11 at 10:57, Ian Campbell <Ian.Campbell@...rix.com> wrote:
> > > > > > On Thu, 2011-12-22 at 09:08 +0000, Jan Beulich wrote:
> > > > > >> The 'name', 'owner', and 'mod_name' members are redundant with the
> > > > > >> identically named fields in the 'driver' sub-structure. Rather than
> > > > > >> switching each instance to specify these fields explicitly, introduce
> > > > > >> a macro to simplify this.
> > > > > >> 
> > > > > >> Eliminate further redundancy by allowing the drvname argument to
> > > > > >> DEFINE_XENBUS_DRIVER() to be blank (in which case the first entry from
> > > > > >> the ID table will be used for .driver.name).
> > > > > > 
> > > > > > Any reason not to always use DRV_NAME here (which is generally a bit
> > > > > > more specific e.g. "xen-foofront" rather than "foo") and rely on the id
> > > > > > table for the shorter names used in xenstore?
> > > > > 
> > > > > That would imply that DRV_NAME is always defined, but I don't
> > > > > see this being the case.
> > > > 
> > > > My mistake, I thought it was a Kbuild thing.
> > > 
> > > You're maybe thinking of KBUILD_MODNAME.
> > 
> > Yes, I think I was.
> 
> Ian, are you OK with this patch? I think Jan needs to repost once more with the
> "pciback" -> DRV_NAME change and then it is OK?

I don't much like the style of leaving macro parameters blank -- I'd
much rather have things be explicitly specified and live with the slight
duplication in cases where the device name happens to match an entry in
the id list. But it's not a show stopper for me.

> I've tested it with all backends, except the pciback one, and I see no regressions
> with 'xl' or 'xm' toolstack.

Great!

Presumably there is no actual change to sysfs arising from this patch.

Ian.

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists