[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20120224112908.3e00e5ce@nehalam.linuxnetplumber.net>
Date: Fri, 24 Feb 2012 11:29:08 -0800
From: Stephen Hemminger <shemminger@...tta.com>
To: Ben Hutchings <bhutchings@...arflare.com>
Cc: David Miller <davem@...emloft.net>, <netdev@...r.kernel.org>
Subject: Re: [PATCH] gre: fix spelling in comments
On Fri, 24 Feb 2012 19:17:25 +0000
Ben Hutchings <bhutchings@...arflare.com> wrote:
> On Fri, 2012-02-24 at 10:08 -0800, Stephen Hemminger wrote:
> > The original spelling and bad word choice makes these comments hard to read.
>
> Not to mention weird capitalisation.
>
> > Signed-off-by: Stephen Hemminger <shemminger@...tta.com>
> >
> > --- a/net/ipv4/ip_gre.c 2012-02-24 10:04:41.007678920 -0800
> > +++ b/net/ipv4/ip_gre.c 2012-02-24 10:07:54.421769389 -0800
> > @@ -65,7 +65,7 @@
> > it is infeasible task. The most general solutions would be
> > to keep skb->encapsulation counter (sort of local ttl),
>
> 'ttl' is an abbreviation, and not a variable name here, so should be
> capitalised.
>
> > and silently drop packet when it expires. It is a good
> > - solution, but it supposes maintaing new variable in ALL
> > + solution, but it supposes maintaining new variable in ALL
> > skb, even if no tunneling is used.
> >
> > Current solution: xmit_recursion breaks dead loops. This is a percpu
> > @@ -91,14 +91,14 @@
> >
> > One of them is to parse packet trying to detect inner encapsulation
> > made by our node. It is difficult or even impossible, especially,
> > - taking into account fragmentation. TO be short, tt is not solution at all.
> > + taking into account fragmentation. TO be short, ttl is not solution at all.
>
> 'TO' shouldn't be capitalised.
>
> >
> > Current solution: The solution was UNEXPECTEDLY SIMPLE.
>
> 'UNEXPECTEDLY SIMPLE' shouldn't be capitalised. Also, after the passage
> of a few years, this is perhaps no longer unexpected at all...
>
> > We force DF flag on tunnels with preconfigured hop limit,
> > that is ALL. :-) Well, it does not remove the problem completely,
> > but exponential growth of network traffic is changed to linear
> > (branches, that exceed pmtu are pruned) and tunnel mtu
>
> 'pmtu' and 'mtu' should be capitalised.
>
> > - fastly degrades to value <68, where looping stops.
> > + rapidly degrades to value <68, where looping stops.
> > Yes, it is not good if there exists a router in the loop,
> > which does not force DF, even when encapsulating packets have DF set.
> > But it is not our problem! Nobody could accuse us, we made
> > @@ -457,8 +457,8 @@ static void ipgre_err(struct sk_buff *sk
> > GRE tunnels with enabled checksum. Tell them "thank you".
> >
> > Well, I wonder, rfc1812 was written by Cisco employee,
>
> 'rfc' should be capitalised.
>
> > - what the hell these idiots break standrads established
> > - by themself???
> > + what the hell these idiots break standards established
> > + by themselves???
> > */
> >
> > const struct iphdr *iph = (const struct iphdr *)skb->data;
>
> Insults also detract from the readability as a technical description.
>
> Ben.
>
I agree, just didn't want to got that far. But yes
those should be fixed as well.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists