[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1334105782-9286-1-git-send-email-jim.cromie@gmail.com>
Date: Tue, 10 Apr 2012 18:56:22 -0600
From: Jim Cromie <jim.cromie@...il.com>
To: netdev@...r.kernel.org, davem@...emloft.net,
jeffrey.t.kirsher@...el.com, joe@...ches.com, florian@...nwrt.org,
netdev@...deepdalvi.com
Cc: trivial@...r.kernel.org, Jim Cromie <jim.cromie@...il.com>
Subject: [PATCH 07/11] ethernet: replace open-coded ARRAY_SIZE with macro
Signed-off-by: Jim Cromie <jim.cromie@...il.com>
---
drivers/net/ethernet/s6gmac.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/net/ethernet/s6gmac.c b/drivers/net/ethernet/s6gmac.c
index 1895605..8e9fda0 100644
--- a/drivers/net/ethernet/s6gmac.c
+++ b/drivers/net/ethernet/s6gmac.c
@@ -937,7 +937,7 @@ static struct net_device_stats *s6gmac_stats(struct net_device *dev)
do {
unsigned long flags;
spin_lock_irqsave(&pd->lock, flags);
- for (i = 0; i < sizeof(pd->stats) / sizeof(unsigned long); i++)
+ for (i = 0; i < ARRAY_SIZE(pd->stats); i++)
pd->stats[i] =
pd->carry[i] << (S6_GMAC_STAT_SIZE_MIN - 1);
s6gmac_stats_collect(pd, &statinf[0][0]);
--
1.7.8.1
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists