[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20120511.010109.1698578316660207883.davem@davemloft.net>
Date: Fri, 11 May 2012 01:01:09 -0400 (EDT)
From: David Miller <davem@...emloft.net>
To: mgorman@...e.de
Cc: akpm@...ux-foundation.org, linux-mm@...ck.org,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org,
neilb@...e.de, a.p.zijlstra@...llo.nl, michaelc@...wisc.edu,
emunson@...bm.net
Subject: Re: [PATCH 12/17] netvm: Propagate page->pfmemalloc from
netdev_alloc_page to skb
From: Mel Gorman <mgorman@...e.de>
Date: Thu, 10 May 2012 14:45:05 +0100
> +/**
> + * propagate_pfmemalloc_skb - Propagate pfmemalloc if skb is allocated after RX page
> + * @page: The page that was allocated from netdev_alloc_page
> + * @skb: The skb that may need pfmemalloc set
> + */
> +static inline void propagate_pfmemalloc_skb(struct page *page,
> + struct sk_buff *skb)
Please use consistent prefixes in the names for new interfaces.
This one should probably be named "skb_propagate_pfmemalloc()" and
go into skbuff.h since it needs no knowledge of netdevices.
In fact all of these routines are about propagation of attributes
into SKBs, irregardless of any netdevice details.
Therefore they should probably all be named skb_*() and go into
skbuff.h
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists