lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 15 Aug 2012 15:14:03 -0700 (PDT)
From:	David Miller <davem@...emloft.net>
To:	fan.du@...driver.com
Cc:	netdev@...r.kernel.org
Subject: Re: [PATCH v2] XFRM: remove redundant parameter "int dir" in
 struct xfrm_mgr.acquire

From: Fan Du <fan.du@...driver.com>
Date: Wed, 15 Aug 2012 10:13:47 +0800

> Sematically speaking, xfrm_mgr.acquire is called when kernel intends to ask
> user space IKE daemon to negotiate SAs with peers. IOW the direction will
> *always* be XFRM_POLICY_OUT, so remove int dir for clarity.
> 
> Signed-off-by: Fan Du <fan.du@...driver.com>
> ---
> Changelog for V2:
> 	- Remove "int dir" in build_acquire parameter suggested by Steffen Klassert.

Applied, thanks.

Please use lowercase "xfrm: " for subsystem indications in your subject
lines, I fixed it up this time.

Thanks again.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists