[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <cover.1348332940.git.richardcochran@gmail.com>
Date: Sat, 22 Sep 2012 19:02:00 +0200
From: Richard Cochran <richardcochran@...il.com>
To: <netdev@...r.kernel.org>
Cc: Ben Hutchings <bhutchings@...arflare.com>,
David Miller <davem@...emloft.net>,
Jacob Keller <jacob.e.keller@...el.com>,
Jeff Kirsher <jeffrey.t.kirsher@...el.com>,
John Stultz <john.stultz@...aro.org>,
Matthew Vick <matthew.vick@...el.com>
Subject: [PATCH V3 net-next 0/4] Two new PTP Hardware Clock features
This patch series adds two new features to the PHC code.
* ChangeLog
** V3
- Use the correct parent device in the solarflare driver.
- Expand the sysfs documentation of clock_name.
- Also document the clock_name field in the header file.
** V2
- Preserves the clock_name attribute as it was meant to be, instead
of making any changes to it.
- Covers the registration API change in the brand new solarflare phc
device, which was overlooked in V1.
The first two patches let a user program find out the previously
dialed frequency adjustment. This is primarily useful when restarting
a PTP service, since without this information, the presumably correct
adjustment will bias the new frequency estimation.
The third patch links the phc class device to its parent device within
the driver model and sysfs.
The fourth patch adds a bit more documentation of the sysfs clock_name
attribute. This should help clarify the naming scheme.
Thanks,
Richard
Richard Cochran (4):
ptp: remember the adjusted frequency
ptp: provide the clock's adjusted frequency
ptp: link the phc device to its parent device
ptp: clarify the clock_name sysfs attribute
Documentation/ABI/testing/sysfs-ptp | 6 +++++-
drivers/net/ethernet/freescale/gianfar_ptp.c | 2 +-
drivers/net/ethernet/intel/igb/igb_ptp.c | 3 ++-
drivers/net/ethernet/intel/ixgbe/ixgbe_ptp.c | 3 ++-
drivers/net/ethernet/sfc/ptp.c | 3 ++-
drivers/net/phy/dp83640.c | 2 +-
drivers/ptp/ptp_clock.c | 11 +++++++++--
drivers/ptp/ptp_ixp46x.c | 2 +-
drivers/ptp/ptp_pch.c | 2 +-
drivers/ptp/ptp_private.h | 1 +
include/linux/ptp_clock_kernel.h | 11 ++++++++---
11 files changed, 33 insertions(+), 13 deletions(-)
--
1.7.2.5
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists