[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1353103453.2743.44.camel@bwh-desktop.uk.solarflarecom.com>
Date: Fri, 16 Nov 2012 22:04:13 +0000
From: Ben Hutchings <bhutchings@...arflare.com>
To: Vlad Yasevich <vyasevic@...hat.com>
CC: <netdev@...r.kernel.org>, <eric.dumazet@...il.com>,
<davem@...emloft.com>
Subject: Re: [RFC PATCH 13/13] ipv6: Pull IPv6 GSO registration out of the
module
On Tue, 2012-11-13 at 20:24 -0500, Vlad Yasevich wrote:
> Sing GSO support is now separate, pull it out of the module
Sing? Can we dance, too?
> and make it its own init call.
> Remove the cleanup functions as they are no longer called.
[...]
> --- a/include/net/protocol.h
> +++ b/include/net/protocol.h
> @@ -25,6 +25,7 @@
> #define _PROTOCOL_H
>
> #include <linux/in6.h>
> +#include <linux/skbuff.h>
> #if IS_ENABLED(CONFIG_IPV6)
> #include <linux/ipv6.h>
> #endif
> @@ -59,8 +60,6 @@ struct inet6_protocol {
>
> #define INET6_PROTO_NOPOLICY 0x1
> #define INET6_PROTO_FINAL 0x2
> -/* This should be set for any extension header which is compatible with GSO. */
> -#define INET6_PROTO_GSO_EXTHDR 0x4
> #endif
>
> struct net_offload {
> @@ -72,6 +71,8 @@ struct net_offload {
> int (*gro_complete)(struct sk_buff *skb);
> unsigned int flags; /* Flags used by IPv6 for now */
> };
> +/* This should be set for any extension header which is compatible with GSO. */
> +#define INET6_PROTO_GSO_EXTHDR 0x1
[...]
Should be renamed to INET6_OFFLOAD_GSO_EXTHDR, matching the new
structure name.
Ben.
--
Ben Hutchings, Staff Engineer, Solarflare
Not speaking for my employer; that's the marketing department's job.
They asked us to note that Solarflare product names are trademarked.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists