[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20130121174824.GA27956@sapphire.tkos.co.il>
Date: Mon, 21 Jan 2013 19:48:26 +0200
From: Baruch Siach <baruch@...s.co.il>
To: Sascha Hauer <s.hauer@...gutronix.de>
Cc: netdev@...r.kernel.org, shawn.guo@...aro.org, davem@...emloft.net,
linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH 1/2] net: fec: refactor dt probing
Hi Sascha,
On Mon, Jan 21, 2013 at 09:37:54AM +0100, Sascha Hauer wrote:
> For devicetree parsing only the fec_get_phy_mode_dt() is
> available. Rename it to fec_probe_dt() to be able to add more devicetree
> parsing to it.
>
> Signed-off-by: Sascha Hauer <s.hauer@...gutronix.de>
> ---
[...]
> -static int fec_get_phy_mode_dt(struct platform_device *pdev)
> +static int fec_probe_dt(struct fec_enet_private *fep)
> {
> - struct device_node *np = pdev->dev.of_node;
> + struct device_node *np = fep->pdev->dev.of_node;
>
> - if (np)
> - return of_get_phy_mode(np);
> + if (!np)
> + return -ENODEV;
> +
> + fep->phy_interface = of_get_phy_mode(np);
>
> return -ENODEV;
Maybe return fep->phy_interface?
baruch
--
http://baruch.siach.name/blog/ ~. .~ Tk Open Systems
=}------------------------------------------------ooO--U--Ooo------------{=
- baruch@...s.co.il - tel: +972.2.679.5364, http://www.tkos.co.il -
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists