[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1363111995-26866-1-git-send-email-silviupopescu1990@gmail.com>
Date: Tue, 12 Mar 2013 20:13:15 +0200
From: Silviu-Mihai Popescu <silviupopescu1990@...il.com>
To: linux-bluetooth@...r.kernel.org
Cc: marcel@...tmann.org, gustavo@...ovan.org, johan.hedberg@...il.com,
davem@...emloft.net, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org,
Silviu-Mihai Popescu <silviupopescu1990@...il.com>
Subject: [PATCH] bluetooth: use PTR_RET instead of IS_ERR + PTR_ERR
This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase
readability.
Signed-off-by: Silviu-Mihai Popescu <silviupopescu1990@...il.com>
---
net/bluetooth/hci_sysfs.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/net/bluetooth/hci_sysfs.c b/net/bluetooth/hci_sysfs.c
index 23b4e24..6fb5065 100644
--- a/net/bluetooth/hci_sysfs.c
+++ b/net/bluetooth/hci_sysfs.c
@@ -590,10 +590,7 @@ int __init bt_sysfs_init(void)
bt_debugfs = debugfs_create_dir("bluetooth", NULL);
bt_class = class_create(THIS_MODULE, "bluetooth");
- if (IS_ERR(bt_class))
- return PTR_ERR(bt_class);
-
- return 0;
+ return PTR_RET(bt_class)
}
void bt_sysfs_cleanup(void)
--
1.7.9.5
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists