[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <OF9BEEA27A.EA477839-ON87257B90.0045D6A5-85257B90.00463241@us.ibm.com>
Date: Thu, 20 Jun 2013 08:46:42 -0400
From: David Stevens <dlstevens@...ibm.com>
To: Pravin B Shelar <pshelar@...ira.com>
Cc: dev@...nvswitch.org, netdev@...r.kernel.org,
netdev-owner@...r.kernel.org, Pravin B Shelar <pshelar@...ira.com>
Subject: Re: [PATCH net-next 5/8] vxlan: Factor out vxlan send api.
> From: Pravin B Shelar <pshelar@...ira.com>
> @@ -1205,13 +1222,13 @@ static netdev_tx_t vxlan_xmit(struct sk_buff
> *skb, struct net_device *dev)
>
> skb1 = skb_clone(skb, GFP_ATOMIC);
> if (skb1) {
> - rc1 = vxlan_xmit_one(skb1, dev, rdst, did_rsc);
> + rc1 = __vxlan_xmit(skb1, dev, rdst, did_rsc);
> if (rc == NETDEV_TX_OK)
> rc = rc1;
> }
> }
>
> - rc1 = vxlan_xmit_one(skb, dev, rdst0, did_rsc);
> + rc1 = __vxlan_xmit(skb, dev, rdst0, did_rsc);
> if (rc == NETDEV_TX_OK)
> rc = rc1;
> return rc;
You're changing the name of the function that sends a
packet to one destination because you think "__vxlan_xmit"
is more descriptive than "vxlan_xmit_one" ?
+-DLS
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists