[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAL1RGDX5mHj5oVqFhQ4Ssr25jpL4rV2Tv=zXvLOZfwupJ0gqJw@mail.gmail.com>
Date: Mon, 1 Jul 2013 10:49:47 -0700
From: Roland Dreier <roland@...nel.org>
To: Or Gerlitz <or.gerlitz@...il.com>
Cc: Eli Cohen <eli@....mellanox.co.il>,
"linux-rdma@...r.kernel.org" <linux-rdma@...r.kernel.org>,
Eli Cohen <eli@...lanox.com>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>
Subject: Re: [PATCH for-next 0/8] Add Mellanox mlx5 driver for Connect-IB devices
So I'm inclined to apply the mlx5 driver for 3.11, since it's a
completely new driver. However, reading through it so far I had the
following comments, and I'd like these cleanups addressed along with
Dave Miller's:
- The debug mask complexity seems unnecessary now that pr_debug() is
controllable at runtime with the DYNAMIC_DEBUG stuff. We should get
rid of the extra level of indirection.
- I think the active flag for the health check timer is unnecessary.
It can just be stopped with del_timer_sync().
- Many places use "foo_spl" as a name, and in the Linux kernel
"foo_lock" would be much more idiomatic and easier to read.
- In:
+struct mlx5_cmd {
...
+ struct mlx5_cmd_stats stats[0x80a];
the 0x80a magic number really needs to have a name.
- R.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists