[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1374649819.18818.5.camel@joe-AO722>
Date: Wed, 24 Jul 2013 00:10:19 -0700
From: Joe Perches <joe@...ches.com>
To: Wang Sheng-Hui <shhuiw@...il.com>
Cc: Jay Vosburgh <fubar@...ibm.com>,
Andy Gospodarek <andy@...yhouse.net>, netdev@...r.kernel.org
Subject: Re: [PATCH] bonding: use pre-defined macro in bond_mode_name
instead of magic number 0
On Wed, 2013-07-24 at 14:53 +0800, Wang Sheng-Hui wrote:
> We have BOND_MODE_ROUNDROBIN pre-defined as 0, and it's the lowest mode number.
> Use it to check the arg lower bound instead of magic number 0 in bond_mode_name.
[]
> diff --git a/drivers/net/bonding/bond_main.c b/drivers/net/bonding/bond_main.c
[]
> @@ -273,7 +273,7 @@ const char *bond_mode_name(int mode)
> [BOND_MODE_ALB] = "adaptive load balancing",
> };
>
> - if (mode < 0 || mode > BOND_MODE_ALB)
> + if (mode < BOND_MODE_ROUNDROBIN || mode > BOND_MODE_ALB)
> return "unknown";
>
> return names[mode];
Probably be simpler, less confusing, and more normal style
to use a switch case.
switch (mode) {
case BOND_MODE_ROUNDROBIN:
return "load balancing (round-robin)";
case BOND_MODE_ACTIVEBACKUP:
return "fault-tolerance (active-backup)";
case BOND_MODE_XOR:
return "load balancing (xor)";
case BOND_MODE_BROADCAST;
return "fault-tolerance (broadcast)";
case BOND_MODE_8023AD:
return "IEEE 802.3ad Dynamic link aggregation";
case BOND_MODE_TLB:
return "transmit load balancing";
case BOND_MODE_ALB:
return "adaptive load balancing";
default:
return "unknown";
}
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists