[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20130726.135409.1813499553216352267.davem@davemloft.net>
Date: Fri, 26 Jul 2013 13:54:09 -0700 (PDT)
From: David Miller <davem@...emloft.net>
To: shhuiw@...il.com
Cc: fubar@...ibm.com, andy@...yhouse.net, netdev@...r.kernel.org
Subject: Re: [PATCH] bonding: use pre-defined macro in bond_mode_name
instead of magic number 0
From: Wang Sheng-Hui <shhuiw@...il.com>
Date: Wed, 24 Jul 2013 14:53:26 +0800
> We have BOND_MODE_ROUNDROBIN pre-defined as 0, and it's the lowest
> mode number.
> Use it to check the arg lower bound instead of magic number 0 in
> bond_mode_name.
>
> Signed-off-by: Wang Sheng-Hui <shhuiw@...il.com>
> ---
> drivers/net/bonding/bond_main.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/net/bonding/bond_main.c
> b/drivers/net/bonding/bond_main.c
> index 07f257d4..5890def 100644
> --- a/drivers/net/bonding/bond_main.c
> +++ b/drivers/net/bonding/bond_main.c
> @@ -273,7 +273,7 @@ const char *bond_mode_name(int mode)
> [BOND_MODE_ALB] = "adaptive load balancing",
> };
>
> - if (mode < 0 || mode > BOND_MODE_ALB)
> + if (mode < BOND_MODE_ROUNDROBIN || mode > BOND_MODE_ALB)
> return "unknown";
>
> return names[mode];
I applied this version of your patch, thanks.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists