[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <AE90C24D6B3A694183C094C60CF0A2F6026B7332@saturn3.aculab.com>
Date: Fri, 13 Sep 2013 11:55:34 +0100
From: "David Laight" <David.Laight@...LAB.COM>
To: "Dan Carpenter" <dan.carpenter@...cle.com>
Cc: "Jeff Kirsher" <jeffrey.t.kirsher@...el.com>,
"Jesse Brandeburg" <jesse.brandeburg@...el.com>,
"Bruce Allan" <bruce.w.allan@...el.com>,
"Carolyn Wyborny" <carolyn.wyborny@...el.com>,
"Don Skidmore" <donald.c.skidmore@...el.com>,
"Greg Rose" <gregory.v.rose@...el.com>,
"Peter P Waskiewicz Jr" <peter.p.waskiewicz.jr@...el.com>,
"Alex Duyck" <alexander.h.duyck@...el.com>,
"John Ronciak" <john.ronciak@...el.com>,
"Tushar Dave" <tushar.n.dave@...el.com>,
"David S. Miller" <davem@...emloft.net>,
"Mitch Williams" <mitch.a.williams@...el.com>,
"Patrick McHardy" <kaber@...sh.net>,
"Greg Kroah-Hartman" <gregkh@...uxfoundation.org>,
<e1000-devel@...ts.sourceforge.net>, <netdev@...r.kernel.org>,
<kernel-janitors@...r.kernel.org>
Subject: RE: [patch -stable] igbvf: integer wrapping bug setting the mtu
> > > static int igbvf_change_mtu(struct net_device *netdev, int new_mtu)
> > > {
> > > struct igbvf_adapter *adapter = netdev_priv(netdev);
> > > - int max_frame = new_mtu + ETH_HLEN + ETH_FCS_LEN;
> > > + unsigned int max_frame = new_mtu + ETH_HLEN + ETH_FCS_LEN;
> > >
> > > if ((new_mtu < 68) || (max_frame > MAX_JUMBO_FRAME_SIZE)) {
> > > dev_err(&adapter->pdev->dev, "Invalid MTU setting\n");
> >
> > It is safer to check:
> > if ((new_mtu < 68) || (new_mtu > MAX_JUMBO_FRAME_SIZE - ETH_HLEN - ETH_FCS_LEN)) {
> >
>
> I believe my fix is already 100% safe... Where is the bug in my code?
>
> Your fix harder to read because of the additional math and because it's
> checking "new_mtu" when we care about "max_frame".
I don't like the window check on two variables.
However if ETH_HLEN and ETH_FCS_LEN are 'int' (not an unsigned type)
and 'new_mtu' is just below MAX_INT then the signed arithmetic
could overflow - generating an indeterminate value.
In which case 'max_frame' might not exceed MAX_JUMBO_FRAME_SIZE.
David
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists