[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1383525449.3042.27.camel@joe-AO722>
Date: Sun, 03 Nov 2013 16:37:29 -0800
From: Joe Perches <joe@...ches.com>
To: Govindarajulu Varadarajan <govindarajulu90@...il.com>
Cc: davem@...emloft.net, gregkh@...uxfoundation.org,
linux-usb@...r.kernel.org, linux-kernel@...r.kernel.org,
schwidefsky@...ibm.com, linville@...driver.com,
linux-wireless@...r.kernel.org, netdev@...r.kernel.org,
IvDoorn@...il.com, sbhatewara@...are.com, samuel@...tiz.org,
chas@....nrl.navy.mil, roland@...nel.org, isdn@...ux-pingi.de,
jcliburn@...il.com, benve@...co.com, ssujith@...co.com,
jeffrey.t.kirsher@...el.com, jesse.brandeburg@...el.com,
shahed.shaikh@...gic.com, apw@...onical.com
Subject: Re: [PATCH net-next 13/13] scripts/checkpatch.pl: Add
dev_kfree_skb*(NULL) check to checkpatch
On Sat, 2013-11-02 at 19:17 +0530, Govindarajulu Varadarajan wrote:
> Signed-off-by: Govindarajulu Varadarajan <govindarajulu90@...il.com>
[]
> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
[]
> @@ -3719,7 +3719,7 @@ sub process {
> # check for needless "if (<foo>) fn(<foo>)" uses
> if ($prevline =~ /\bif\s*\(\s*($Lval)\s*\)/) {
> my $expr = '\s*\(\s*' . quotemeta($1) . '\s*\)\s*;';
> - if ($line =~ /\b(kfree|usb_free_urb|debugfs_remove(?:_recursive)?)$expr/) {
> + if ($line =~ /\b(kfree|dev_kfree_skb|dev_kfree_skb_any|dev_kfree_skb_irq|usb_free_urb|debugfs_remove(?:_recursive)?)$expr/) {
> WARN('NEEDLESS_IF',
> "$1(NULL) is safe this check is probably not required\n" . $hereprev);
> }
OK, but I think this is easier to read as
dev_kfree_skb(?:_skb|_any|_irq)?
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists