[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1384495793-22534-1-git-send-email-f.fainelli@gmail.com>
Date: Fri, 15 Nov 2013 06:09:53 +0000
From: Florian Fainelli <f.fainelli@...il.com>
To: davem@...emloft.net
Cc: netdev@...r.kernel.org, Florian Fainelli <f.fainelli@...il.com>
Subject: [PATCH net-next] net: phy: use phy_init_hw instead of open-coding it
We already have a helper function which verifies a PHY device driver
implements a config_init callback, then calls phy_scan_fixups() and
ultimately calls the config_init callback. Use that instead of open
coding it.
Signed-off-by: Florian Fainelli <f.fainelli@...il.com>
---
drivers/net/phy/phy.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c
index 36c6994..1e5de8c 100644
--- a/drivers/net/phy/phy.c
+++ b/drivers/net/phy/phy.c
@@ -360,11 +360,8 @@ int phy_mii_ioctl(struct phy_device *phydev,
mii_data->reg_num, val);
if (mii_data->reg_num == MII_BMCR &&
- val & BMCR_RESET &&
- phydev->drv->config_init) {
- phy_scan_fixups(phydev);
- phydev->drv->config_init(phydev);
- }
+ val & BMCR_RESET)
+ phy_init_hw(phydev);
break;
case SIOCSHWTSTAMP:
--
1.8.3.2
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists