lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <52AF0C03.40409@gmail.com>
Date:	Mon, 16 Dec 2013 22:19:47 +0800
From:	Wang Weidong <weidong1991.wang@...il.com>
To:	David Laight <David.Laight@...LAB.COM>, jon.maloy@...csson.com,
	allan.stephens@...driver.com, davem@...emloft.net
CC:	erik.hugne@...csson.com, maloy@...jonn.com, netdev@...r.kernel.org
Subject: Re: [PATCH net-next 2/4] tipc: kill unnecessary goto's

From: Wang weidong <wangweidong1@...wei.com>

On 2013/12/16 21:30, David Laight wrote:
>> From: Wang Weidong
>> Sent: 16 December 2013 12:40
>> Remove a number of needless 'goto exit' in send_stream
>> when the socket is in an unconnected state.
>> This patch is cosmetic and does not alter the operation of
>> TIPC in any way.
>>
>> Reviewed-by: Jon Maloy <jon.maloy@...csson.com>
>> Reviewed-by: Erik Hugne <erik.hugne@...csson.com>
>> Signed-off-by: Wang Weidong <wangweidong1@...wei.com>
>> ---
>>   net/tipc/socket.c | 14 ++++++--------
>>   1 file changed, 6 insertions(+), 8 deletions(-)
>>
>> diff --git a/net/tipc/socket.c b/net/tipc/socket.c
>> index 32037c5..844bf34 100644
>> --- a/net/tipc/socket.c
>> +++ b/net/tipc/socket.c
>> @@ -751,16 +751,14 @@ static int send_stream(struct kiocb *iocb, struct socket *sock,
>>
>>   	/* Handle special cases where there is no connection */
>>   	if (unlikely(sock->state != SS_CONNECTED)) {
>> -		if (sock->state == SS_UNCONNECTED) {
>> +		res = -ENOTCONN;
>> +
>> +		if (sock->state == SS_UNCONNECTED)
>>   			res = send_packet(NULL, sock, m, total_len);
>> -			goto exit;
>> -		} else if () {
>> +		else if (sock->state == SS_DISCONNECTING)
>>   			res = -EPIPE;
>> -			goto exit;
>> -		} else {
>> -			res = -ENOTCONN;
>> -			goto exit;
>> -		}
>> +
>> +		goto exit;
>
> I'm not sure that 'removing needless gotos' is a good description of the change.
> Possibly the code is easier to read with only one goto, ymmv.

I thinks so.

> You could remove the 'else' after the 'goto'.
> Maybe the easiest to read is:
> 	if (sock->state == SS_UNCONNECTED)
> 		res = send_packet(NULL, sock, m, total_len);
> 	else
> 		res = sock->state == SS_DISCONNECTING ? -EPIPE : -ENOTCONN;
> 	goto exit;
>
> 	David
>
Thanks for your suggestion. I will fix it too.

Regards.
Wang
>
>
> --
> To unsubscribe from this list: send the line "unsubscribe netdev" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ