[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20131218140654.GB10471@neilslaptop.think-freely.org>
Date: Wed, 18 Dec 2013 09:06:54 -0500
From: Neil Horman <nhorman@...driver.com>
To: Wang Weidong <wangweidong1@...wei.com>
Cc: David Miller <davem@...emloft.net>,
Vlad Yasevich <vyasevich@...il.com>, netdev@...r.kernel.org,
linux-sctp@...r.kernel.org
Subject: Re: [PATCH net-next 2/3] sctp: remove the never used 'return' and,
redundant 'break'
On Wed, Dec 18, 2013 at 05:20:32PM +0800, Wang Weidong wrote:
> In switch() had do return, and never use the 'return NULL'. The
> 'break' after return or goto has no effect. Remove it.
>
> Signed-off-by: Wang Weidong <wangweidong1@...wei.com>
> ---
> net/sctp/input.c | 5 -----
> 1 file changed, 5 deletions(-)
>
> diff --git a/net/sctp/input.c b/net/sctp/input.c
> index 2a192a7..c956dc9 100644
> --- a/net/sctp/input.c
> +++ b/net/sctp/input.c
> @@ -1120,15 +1120,10 @@ static struct sctp_association *__sctp_rcv_lookup_harder(struct net *net,
> case SCTP_CID_INIT:
> case SCTP_CID_INIT_ACK:
> return __sctp_rcv_init_lookup(net, skb, laddr, transportp);
> - break;
>
> default:
> return __sctp_rcv_walk_lookup(net, skb, laddr, transportp);
> - break;
> }
> -
> -
> - return NULL;
> }
>
> /* Lookup an association for an inbound skb. */
> --
> 1.7.12
>
>
>
If you're going to do this, it seems like you may just as well convert the
switch to be if (ch->type && ch->type <= SCTP_CID_INIT_ACK) {...} else {...}
That seems like it would be more readable to me.
Neil
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists