[<prev] [next>] [day] [month] [year] [list]
Message-ID: <CA+mtBx-g2H8dgBSNnKPg1aZQtUg97sTysTuPMPazCquRV_E0Qg@mail.gmail.com>
Date: Tue, 7 Jan 2014 11:52:37 -0800
From: Tom Herbert <therbert@...gle.com>
To: Or Gerlitz <or.gerlitz@...il.com>
Cc: Or Gerlitz <ogerlitz@...lanox.com>, Jerry Chu <hkchu@...gle.com>,
Eric Dumazet <edumazet@...gle.com>,
Herbert Xu <herbert@...dor.apana.org.au>,
Linux Netdev List <netdev@...r.kernel.org>,
David Miller <davem@...emloft.net>,
Yan Burman <yanb@...lanox.com>,
Shlomo Pongratz <shlomop@...lanox.com>
Subject: Re: [PATCH net-next V2 3/3] net: Add GRO support for vxlan traffic
On Tue, Jan 7, 2014 at 11:37 AM, Or Gerlitz <or.gerlitz@...il.com> wrote:
> On Tue, Jan 7, 2014 at 8:08 PM, Tom Herbert <therbert@...gle.com> wrote:
>>
>> On Tue, Jan 7, 2014 at 7:29 AM, Or Gerlitz <ogerlitz@...lanox.com> wrote:
>> > +static struct sk_buff **vxlan_gro_receive(struct sk_buff **head, struct
>> > sk_buff *skb)
>> > +{
>> > + struct sk_buff *p, **pp = NULL;
>> > + struct vxlanhdr *vh, *vh2;
>> > + struct ethhdr *eh;
>> > + unsigned int hlen, off, off_eth;
>> > + const struct packet_offload *ptype;
>> > + __be16 type;
>> > + int flush = 1;
>> > +
>> > + off = skb_gro_offset(skb);
>> > + hlen = off + sizeof(*vh);
>> > + vh = skb_gro_header_fast(skb, off);
>> > + if (skb_gro_header_hard(skb, hlen)) {
>> > + vh = skb_gro_header_slow(skb, hlen, off);
>> > + if (unlikely(!vh))
>> > + goto out;
>> > + }
>> > +
>> > + flush = 0;
>> > +
>> > + for (p = *head; p; p = p->next) {
>> > + if (!NAPI_GRO_CB(p)->same_flow)
>> > + continue;
>> > +
>> > + vh2 = (struct vxlanhdr *)(p->data + off);
>> > + if (vh->vx_vni ^ vh2->vx_vni) {
>>
>> Why ^ instead of != ?
>
>
> The XOR approach is very popular in the GRO stack, e.g see the IPv4 chain of
> inet_gro_receive() && tcp_gro_receive(), I guess this might relates to more
> efficient assembly code for ^ vs. != and/or the fast/elegant transitive
> nature of that operator
>
These arguments may have applied twenty years ago, but I seriously
doubt this is going to outwit any modern compiler into producing more
efficient code. To me, it's just making code less readable.
>>
>> > + NAPI_GRO_CB(p)->same_flow = 0;
>> > + continue;
>> > + }
>> > + goto found;
>> > + }
>
>
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists