[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1389842050.31367.396.camel@edumazet-glaptop2.roam.corp.google.com>
Date: Wed, 15 Jan 2014 19:14:10 -0800
From: Eric Dumazet <eric.dumazet@...il.com>
To: Daniel Borkmann <dborkman@...hat.com>
Cc: davem@...emloft.net, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org,
Jakub Zawadzki <darkjames-ws@...kjames.pl>,
Hannes Frederic Sowa <hannes@...essinduktion.org>
Subject: Re: [PATCH net-next 1/2] random32: add prandom_u32_lt_N and convert
"misuses" of reciprocal_divide
On Thu, 2014-01-16 at 00:23 +0100, Daniel Borkmann wrote:
> @@ -1220,7 +1219,7 @@ static unsigned int fanout_demux_hash(struct packet_fanout *f,
> struct sk_buff *skb,
> unsigned int num)
> {
> - return reciprocal_divide(skb->rxhash, num);
> + return (u32)(((u64) skb->rxhash * num) >> 32);
> }
>
This is unfortunate.
(This reverts one of your patch : f55d112e529386 )
Please add a helper to explain what's going on here, and on many other
spots we do this computation (as in get_rps_cpu()).
Few people really understand this.
Or keep reciprocal_divide() as is, and introduce a new set of functions
for people really wanting the precise divides.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists