[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <52ED010E.80500@myricom.com>
Date: Sat, 1 Feb 2014 23:13:34 +0900
From: Hyong-Youb Kim <hyong-youb.kim@...icom.com>
To: Sergei Shtylyov <sergei.shtylyov@...entembedded.com>,
Alexander Gordeev <agordeev@...hat.com>,
<linux-kernel@...r.kernel.org>
CC: Hyong-Youb Kim <hykim@...i.com>, <netdev@...r.kernel.org>,
<linux-pci@...r.kernel.org>
Subject: Re: [PATCH 20/34] myri10ge: Use pci_enable_msix_range()
On 2/1/2014 4:24 AM, Sergei Shtylyov wrote:
> Hello.
>
> On 01/31/2014 06:08 PM, Alexander Gordeev wrote:
>
[...]
>> + if (status < 0)
>> + goto disable_msix;
>
> Hm, if enabling MSI failed, we don't need to disable it, right? So,
> perhaps the label should be renamed?
>
The code following disable_msix does not call pci_disable_msix(). It
frees the allocated vector buffer and loads the firmware that uses a
single interrupt vector. So, it is "disable" in the sense that the
driver is not going to use MSI-X vectors. I agree that naming could be
better.
disable_msix:
if (mgp->msix_vectors != NULL) {
kfree(mgp->msix_vectors);
mgp->msix_vectors = NULL;
}
abort_with_fw:
mgp->num_slices = 1;
set_fw_name(mgp, old_fw, old_allocated);
myri10ge_load_firmware(mgp, 0);
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists