[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20140318120558.GA6430@redhat.com>
Date: Tue, 18 Mar 2014 13:05:58 +0100
From: Veaceslav Falico <vfalico@...hat.com>
To: Ding Tianhong <dingtianhong@...wei.com>
Cc: fubar@...ibm.com, andy@...yhouse.net, kaber@...sh.net,
davem@...emloft.net, netdev@...r.kernel.org
Subject: Re: [PATCH net-next v2 2/3] bonding: support QinQ for bond arp
interval
On Tue, Mar 18, 2014 at 06:43:52PM +0800, Ding Tianhong wrote:
...snip...
>- if (vlan_id) {
>- skb = vlan_put_tag(skb, htons(ETH_P_8021Q), vlan_id);
>+ if (outer->vlan_id) {
>+ if (inner->vlan_id) {
>+ pr_debug("inner tag: proto %X vid %X\n",
>+ ntohs(inner->vlan_proto), inner->vlan_id);
>+ skb = __vlan_put_tag(skb, inner->vlan_proto, inner->vlan_id);
>+ if (!skb) {
>+ pr_err("failed to insert inner VLAN tag\n");
>+ return;
>+ }
>+ }
>+
>+ pr_debug("outer reg: proto %X vid %X\n",
>+ ntohs(outer->vlan_proto), outer->vlan_id);
>+ skb = vlan_put_tag(skb, outer->vlan_proto, outer->vlan_id);
If I read correctly then the inner->vlan_proto will always be ETH_P_8021AD,
whilst the outer will also always be ETH_P_8021Q. So I think it'd be a lot
easier (and more readable) to just pass 2 vlan ids, and set those protos
statically - that will save you from adding that new function to vlan core,
fro madding a new struct that you've added here and make it several lines
less.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists