lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 4 Apr 2014 12:17:51 +0530
From:	Jagan Teki <jagannadh.teki@...il.com>
To:	nic_swsd@...ltek.com, romieu@...zoreil.com
Cc:	netdev@...r.kernel.org,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Link up issue on ethernet/realtek/r8169.c

Hi,

I'm using TP-LINK PCIe NIC card on my PCIe Root Complex.

Probing looks fine by setting:
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
PCI: enabling device 0000:00:00.0 (0140 -> 0143)
PCI: enabling device 0000:01:00.0 (0140 -> 0143)
r8169 0000:01:00.0 eth0: RTL8168e/8111e at 0xf006a000,
c0:4a:00:07:18:d4, XID 0c200000 IRQ 89
r8169 0000:01:00.0 eth0: jumbo features [frames: 9200 bytes, tx
checksumming: ko]

But I have an issue while in link is up

$ ifconfig 192.168.1.10 up
r8169 0000:01:00.0: Direct firmware load failed with error -2
r8169 0000:01:00.0: Falling back to user helper
r8169 0000:01:00.0 eth0: unable to load firmware patch
rtl_nic/rtl8168e-2.fw (-2)
r8169 0000:01:00.0 eth0: link down

Looks like firmware loading is failed in open call, Can any one
suggest how to debug further.

thanks!
-- 
Jagan.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists