lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 04 Apr 2014 10:07:54 -0400 (EDT)
From:	David Miller <>
Subject: Re: [patch net-next] net: make packet_type->ak_packet_priv generic

From: Jiri Pirko <>
Date: Fri, 4 Apr 2014 16:03:25 +0200

> Fri, Apr 04, 2014 at 03:54:20PM CEST, wrote:
>>From: Jiri Pirko <>
>>Date: Fri,  4 Apr 2014 14:20:38 +0200
>>> The priv is used now by af_packet. Rename it to make it useable for
>>> others as well. Also, introduce packet_id_match to move the sk matching
>>> from skb_loop_sk to af_packet code where it belongs.
>>> Signed-off-by: Jiri Pirko <>
>>Firstly, net-next is closed.
> Dave, it would be really great if you stick with the same email subject
> when you declare net-next closed. I was looking for "CLOSED" but now the
> subject is "no new feature patches please" which I missed.

Sorry, that's not a reasonable request.

It is very clear from the subject line I choose what the message is
about.  I don't have to use an ALL CAPS subject line "just because"

>>Secondly, submit this with the unmentioned and mysterious "other
>>user", there currently are none.
> There is none atm. But anyway, the struct field name should be generic,
> cause this is not specific to af_packet. Anybody might want to pass a
> "priv".

No, because it makes it clear what the one and only user is.

Any new user would be seriously frowned upon, because this is
an easy side channel for proprietary extensions to the networking.
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists