lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 15 Apr 2014 11:19:21 -0700
From:	Chema Gonzalez <>
To:	Daniel Borkmann <>
Cc:	David Miller <>,
	Eric Dumazet <>,,
Subject: Re: [PATCH] filter: added BPF random opcode

On Tue, Apr 15, 2014 at 9:44 AM, Daniel Borkmann <> wrote:
>>> I think using just "rnd" is cleaner here.
>> I think using always random (in fact I may s/K_RAND/K_RANDOM/g) allows
>> easier grepping.
> I know it's just nitpicking, but I'd be happier if that would
> either be rnd or rand in bpf_asm.
"rand" it is.

>>> This example should rather go into Documentation/networking/filter.txt's
>>> example section, rather than tools/net/ .
>> I'll add it there.
> Ok, thanks.

> For 'playing', I'd rather be happy to add that to the documentation file
> in Documentation/networking/filter.txt where we have other examples, or
> alternatively, if there is really no other way around, a new folder inside
> of Documentation/networking/ .
I think it would be better close to the tools/net/bpf* tools. Anyway,
I removed it for now.

To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists