[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20140504235436.GA32448@breakpoint.cc>
Date: Mon, 5 May 2014 01:54:36 +0200
From: Florian Westphal <fw@...len.de>
To: Cong Wang <xiyou.wangcong@...il.com>
Cc: netdev@...r.kernel.org, "David S. Miller" <davem@...emloft.net>,
Maciej Żenczykowski <maze@...gle.com>,
Florian Westphal <fw@...len.de>,
Eric Dumazet <eric.dumazet@...il.com>
Subject: Re: [Patch net-next] net: rename local_df to ignore_df
Cong Wang <xiyou.wangcong@...il.com> wrote:
> As suggested by several people, rename local_df to ignore_df,
> since it means "ignore df bit if it is set".
Thanks for doing this.
David, this has small conflict with a patch I sent couple of hours ago.
Also, I do have another bug fix patch that will move a function
evaluating skb->local_df around [ ie. targeted at net tree ]
That patch needs more testing but I will send it within next 30 hours.
> diff --git a/net/ipv4/ip_forward.c b/net/ipv4/ip_forward.c
> index be8abe7..8ac422f 100644
> --- a/net/ipv4/ip_forward.c
> +++ b/net/ipv4/ip_forward.c
> @@ -42,12 +42,12 @@
> static bool ip_may_fragment(const struct sk_buff *skb)
> {
> return unlikely((ip_hdr(skb)->frag_off & htons(IP_DF)) == 0) ||
> - !skb->local_df;
> + !skb->ignore_df;
nicely illustrates why the rename is a good idea, IMO.
[ should read '|| skb->ignore_df', the negation is wrong ]
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists