[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <537D0FF1.2070708@cogentembedded.com>
Date: Thu, 22 May 2014 00:43:29 +0400
From: Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
To: Joe Perches <joe@...ches.com>
CC: Manuel Schölling <manuel.schoelling@....de>,
isdn@...ux-pingi.de, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/2] mISDN: Use time_before()
Hello.
On 05/22/2014 12:07 AM, Joe Perches wrote:
>>> To be future-proof and for better readability the time comparisons are modified
>>> to use time_before() instead of plain, error-prone math.
>>> diff --git a/drivers/isdn/mISDN/l1oip_core.c b/drivers/isdn/mISDN/l1oip_core.c
> []
>>> @@ -287,7 +287,7 @@ l1oip_socket_send(struct l1oip *hc, u8 localcodec, u8 channel, u32 chanmask,
>>> p = frame;
>>>
>>> /* restart timer */
>>> - if ((int)(hc->keep_tl.expires-jiffies) < 5 * HZ) {
>>> + if (time_before(hc->keep_tl.expires - 5 * HZ, jiffies)) {
>> Wouldn't it be clearer this way:
>> if (time_before(hc->keep_tl.expires, jiffies + 5 * HZ)) {
>>> del_timer(&hc->keep_tl);
>>> hc->keep_tl.expires = jiffies + L1OIP_KEEPALIVE * HZ;
>>> add_timer(&hc->keep_tl);
> mod_timer?
Done by the 2nd patch.
WBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists