lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 4 Jul 2014 23:33:44 +0200
From:	Arvid Brodin <arvid.brodin@...en.se>
To:	"David S. Miller" <davem@...emloft.net>
CC:	"netdev@...r.kernel.org" <netdev@...r.kernel.org>
Subject: [PATCH net-next 00/10] net/hsr: Use list_head+rcu, better frame dispatch,
 etc.

This patch series is meant to improve the HSR code in several ways:

* Better code readability.
* In general, make the code structure more like the net/bridge code (HSR 
  operates similarly to a bridge, but uses the HSR-specific frame headers to 
  break up rings, instead of the STP protocol).
* Better handling of HSR ports' net_device features.
* Use list_head and the _rcu list traversing routines instead of array of slave 
  devices.
* Make it easy to support HSR Interlink devices (for future Redbox/Quadbox 
  support).
* Somewhat better throughput on non-HAVE_EFFICIENT_UNALIGNED_ACCESS archs, due 
  to lesser copying of skb data.

The code has been tested in a ring together with other HSR nodes running 
unchanged code, on both avr32 and x86_64. There should only be one minor change 
in behaviour from a user perspective:

* Anyone using the Netlink HSR_C_GET_NODE_LIST message to dump the internal 
  node database will notice that the database now also contains the self node.

All patches pass 'checkpatch.pl --ignore CAMELCASE --max-line-length=83 
--strict' with only CHECKs, each of which have been deliberately left in place.

The final code passes sparse checks with no output.


Arvid Brodin (10):
  net/hsr: Better variable names and update of contact info.
  net/hsr: Switch from dev_add_pack() to netdev_rx_handler_register()
  net/hsr: Move to per-hsr device prune timer.
  net/hsr: Operstate handling cleanup.
  net/hsr: Move slave init to hsr_slave.c.
  net/hsr: Use list_head (and rcu) instead of array for slave devices.
  net/hsr: Implemented .ndo_fix_features (better device features
    handling).
  net/hsr: Added SET_NETDEV_DEVTYPE and features |= NETIF_F_NETNS_LOCAL
    to dev_setup.
  net/hsr: Better frame dispatch
  net/hsr: Fix NULL pointer dereference on incomplete hsr_newlink()
    params.

 net/hsr/Makefile       |   3 +-
 net/hsr/hsr_device.c   | 580 +++++++++++++++++++++----------------------------
 net/hsr/hsr_device.h   |  12 +-
 net/hsr/hsr_forward.c  | 368 +++++++++++++++++++++++++++++++
 net/hsr/hsr_forward.h  |  20 ++
 net/hsr/hsr_framereg.c | 481 ++++++++++++++++++++--------------------
 net/hsr/hsr_framereg.h |  45 ++--
 net/hsr/hsr_main.c     | 425 ++++--------------------------------
 net/hsr/hsr_main.h     |  61 ++++--
 net/hsr/hsr_netlink.c  | 102 +++++----
 net/hsr/hsr_netlink.h  |  11 +-
 net/hsr/hsr_slave.c    | 196 +++++++++++++++++
 net/hsr/hsr_slave.h    |  38 ++++
 13 files changed, 1285 insertions(+), 1057 deletions(-)
 create mode 100644 net/hsr/hsr_forward.c
 create mode 100644 net/hsr/hsr_forward.h
 create mode 100644 net/hsr/hsr_slave.c
 create mode 100644 net/hsr/hsr_slave.h

-- 
1.8.3.2

-- 
Arvid Brodin | Consultant (Linux)
ALTEN | Knarrarnäsgatan 7 | SE-164 40 Kista | Sweden
arvid.brodin@...en.se | www.alten.se/en/

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ