lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 25 Jul 2014 01:21:21 +0200
From:	Daniel Borkmann <dborkman@...hat.com>
To:	Alexei Starovoitov <ast@...mgrid.com>
CC:	"David S. Miller" <davem@...emloft.net>, netdev@...r.kernel.org,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH net-next] net: filter: rename 'struct sock_filter_int'
 into 'struct bpf_insn'

On 07/24/2014 11:26 PM, Alexei Starovoitov wrote:
> eBPF is used by socket filtering, seccomp and soon by tracing and
> exposed to userspace, therefore 'sock_filter_int' name is not accurate.
> Rename it to 'bpf_insn'
>
> Signed-off-by: Alexei Starovoitov <ast@...mgrid.com>
> ---
...
>   #define BPF_ALU64_REG(OP, DST, SRC)				\
> -	((struct sock_filter_int) {				\
> +	((struct bpf_insn) {				\

                              ^^^ Please also fix up whitespacing here
                                  and all the other sections below.

>   		.code  = BPF_ALU64 | BPF_OP(OP) | BPF_X,	\
>   		.dst_reg = DST,					\
>   		.src_reg = SRC,					\
> @@ -90,7 +90,7 @@ enum {
>   		.imm   = 0 })
>
>   #define BPF_ALU32_REG(OP, DST, SRC)				\
> -	((struct sock_filter_int) {				\
> +	((struct bpf_insn) {				\
>   		.code  = BPF_ALU | BPF_OP(OP) | BPF_X,		\
>   		.dst_reg = DST,					\
>   		.src_reg = SRC,					\
> @@ -100,7 +100,7 @@ enum {
>   /* ALU ops on immediates, bpf_add|sub|...: dst_reg += imm32 */
>
>   #define BPF_ALU64_IMM(OP, DST, IMM)				\
> -	((struct sock_filter_int) {				\
> +	((struct bpf_insn) {				\
>   		.code  = BPF_ALU64 | BPF_OP(OP) | BPF_K,	\
>   		.dst_reg = DST,					\
>   		.src_reg = 0,					\
> @@ -108,7 +108,7 @@ enum {
>   		.imm   = IMM })
>
>   #define BPF_ALU32_IMM(OP, DST, IMM)				\
> -	((struct sock_filter_int) {				\
> +	((struct bpf_insn) {				\
>   		.code  = BPF_ALU | BPF_OP(OP) | BPF_K,		\
>   		.dst_reg = DST,					\
>   		.src_reg = 0,					\
> @@ -118,7 +118,7 @@ enum {
>   /* Endianess conversion, cpu_to_{l,b}e(), {l,b}e_to_cpu() */
>
>   #define BPF_ENDIAN(TYPE, DST, LEN)				\
> -	((struct sock_filter_int) {				\
> +	((struct bpf_insn) {				\
>   		.code  = BPF_ALU | BPF_END | BPF_SRC(TYPE),	\
>   		.dst_reg = DST,					\
>   		.src_reg = 0,					\
> @@ -128,7 +128,7 @@ enum {
>   /* Short form of mov, dst_reg = src_reg */
>
>   #define BPF_MOV64_REG(DST, SRC)					\
> -	((struct sock_filter_int) {				\
> +	((struct bpf_insn) {				\
>   		.code  = BPF_ALU64 | BPF_MOV | BPF_X,		\
>   		.dst_reg = DST,					\
>   		.src_reg = SRC,					\
> @@ -136,7 +136,7 @@ enum {
>   		.imm   = 0 })
>
>   #define BPF_MOV32_REG(DST, SRC)					\
> -	((struct sock_filter_int) {				\
> +	((struct bpf_insn) {				\
>   		.code  = BPF_ALU | BPF_MOV | BPF_X,		\
>   		.dst_reg = DST,					\
>   		.src_reg = SRC,					\
....
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists