lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 28 Jul 2014 16:44:32 -0700 (PDT)
From:	David Miller <>
Subject: Re: [PATCH] ip_tunnel(ipv4): fix tunnels with "local any remote

From: Cong Wang <>
Date: Mon, 28 Jul 2014 16:39:23 -0700

> On Mon, Jul 28, 2014 at 4:07 PM, Dmitry Popov <> wrote:
>> --- a/include/net/ip_tunnels.h
>> +++ b/include/net/ip_tunnels.h
>> @@ -40,6 +40,7 @@ struct ip_tunnel_prl_entry {
>>  struct ip_tunnel_dst {
>>         struct dst_entry __rcu          *dst;
>> +       __be32                           saddr;
>>  };
> It looks odd to save a source address in some struct named dst,
> maybe it's the time to rename it.

It's an encapsulation struct for plain "struct dst_entry", which is a
path to a destination, or in other words a "route".  A "saddr" is a
valid key for a route.

I see no reason to change the name of this structure, it's perfect.
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists