[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <53FC7C3C.3090901@mellanox.com>
Date: Tue, 26 Aug 2014 15:23:24 +0300
From: Or Gerlitz <ogerlitz@...lanox.com>
To: Jiri Pirko <jiri@...nulli.us>, <netdev@...r.kernel.org>
CC: <davem@...emloft.net>, <nhorman@...driver.com>,
<andy@...yhouse.net>, <tgraf@...g.ch>, <dborkman@...hat.com>,
<jesse@...ira.com>, <pshelar@...ira.com>, <azhou@...ira.com>,
<ben@...adent.org.uk>, <stephen@...workplumber.org>,
<jeffrey.t.kirsher@...el.com>, <vyasevic@...hat.com>,
<xiyou.wangcong@...il.com>, <john.r.fastabend@...el.com>,
<edumazet@...gle.com>, <jhs@...atatu.com>,
<sfeldma@...ulusnetworks.com>, <f.fainelli@...il.com>,
<roopa@...ulusnetworks.com>, <linville@...driver.com>,
<dev@...nvswitch.org>, <jasowang@...hat.com>,
<ebiederm@...ssion.com>, <nicolas.dichtel@...nd.com>,
<ryazanov.s.a@...il.com>, <buytenh@...tstofly.org>,
<aviadr@...lanox.com>, <nbd@...nwrt.org>,
<alexei.starovoitov@...il.com>, <Neil.Jerram@...aswitch.com>,
<ronye@...lanox.com>
Subject: Re: [patch net-next RFC 02/12] net: rename netdev_phys_port_id to
more generic name
On 21/08/2014 19:18, Jiri Pirko wrote:
> --- a/net/core/rtnetlink.c
> +++ b/net/core/rtnetlink.c
> @@ -868,7 +868,7 @@ static noinline size_t if_nlmsg_size(const struct net_device *dev,
> + rtnl_port_size(dev, ext_filter_mask) /* IFLA_VF_PORTS + IFLA_PORT_SELF */
> + rtnl_link_get_size(dev) /* IFLA_LINKINFO */
> + rtnl_link_get_af_size(dev) /* IFLA_AF_SPEC */
> - + nla_total_size(MAX_PHYS_PORT_ID_LEN); /* IFLA_PHYS_PORT_ID */
> + + nla_total_size(MAX_PHYS_ITEM_ID_LEN); /* IFLA_PHYS_PORT_ID */
> }
>
> static int rtnl_vf_ports_fill(struct sk_buff *skb, struct net_device *dev)
> @@ -952,7 +952,7 @@ static int rtnl_port_fill(struct sk_buff *skb, struct net_device *dev,
> static int rtnl_phys_port_id_fill(struct sk_buff *skb, struct net_device *dev)
> {
> int err;
> - struct netdev_phys_port_id ppid;
> + struct netdev_phys_item_id ppid;
>
> err = dev_get_phys_port_id(dev, &ppid);
> if (err) {
> @@ -1196,7 +1196,7 @@ static const struct nla_policy ifla_policy[IFLA_MAX+1] = {
> [IFLA_PROMISCUITY] = { .type = NLA_U32 },
> [IFLA_NUM_TX_QUEUES] = { .type = NLA_U32 },
> [IFLA_NUM_RX_QUEUES] = { .type = NLA_U32 },
> - [IFLA_PHYS_PORT_ID] = { .type = NLA_BINARY, .len = MAX_PHYS_PORT_ID_LEN },
> + [IFLA_PHYS_PORT_ID] = { .type = NLA_BINARY, .len = MAX_PHYS_ITEM_ID_LEN },
> [IFLA_CARRIER_CHANGES] = { .type = NLA_U32 }, /* ignored */
> };
>
just a nit, but if this approach/patch goes in, any reason not to change
IFLA_PHYS_PORT_ID to IFLA_PHYS_ITEM_ID?
Or.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists