[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1410175328.11872.97.camel@edumazet-glaptop2.roam.corp.google.com>
Date: Mon, 08 Sep 2014 04:22:08 -0700
From: Eric Dumazet <eric.dumazet@...il.com>
To: Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
Cc: David Miller <davem@...emloft.net>, netdev <netdev@...r.kernel.org>
Subject: Re: [PATCH net] net: fix skb_page_frag_refill() kerneldoc
On Mon, 2014-09-08 at 15:04 +0400, Sergei Shtylyov wrote:
> Hello.
>
> On 9/8/2014 3:00 PM, Eric Dumazet wrote:
>
> > From: Eric Dumazet <edumazet@...gle.com>
>
> > In commit d9b2938aabf7 ("net: attempt a single high order allocation)
> > I forgot to update kerneldoc, as @prio parameter was renamed to @gfp
>
> > Signed-off-by: Eric Dumazet <edumazet@...gle.com>
> > ---
> > net/core/sock.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
>
> > diff --git a/net/core/sock.c b/net/core/sock.c
> > index d372b4bd3f99..9c3f823e76a9 100644
> > --- a/net/core/sock.c
> > +++ b/net/core/sock.c
> > @@ -1866,7 +1866,7 @@ EXPORT_SYMBOL(sock_alloc_send_skb);
> > * skb_page_frag_refill - check that a page_frag contains enough room
> > * @sz: minimum size of the fragment we want to get
> > * @pfrag: pointer to page_frag
> > - * @prio: priority for memory allocation
> > + * @gfp: priority for memory allocation
>
> 'gfp' is not priority, it's just flags.
This is the usual wording for this in net/core
I changed the name of the argument, not its meaning.
$ scripts/kernel-doc net/core/sock.c >/dev/null
Warning(net/core/sock.c:1874): No description found for parameter 'gfp'
Warning(net/core/sock.c:1874): Excess function parameter 'prio'
description in 'skb_page_frag_refill'
Feel free to submit a net-next patch to change net/core occurrences.
Thanks
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists