lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Sun, 14 Sep 2014 21:08:36 +0300
From:	Kalle Valo <kvalo@...rom.com>
To:	Emmanuel Grumbach <egrumbach@...il.com>
Cc:	Oliver Hartkopp <socketcan@...tkopp.net>,
	Vadim Kochan <vadim4j@...il.com>,
	"John W. Linville" <linville@...driver.com>,
	linux-wireless <linux-wireless@...r.kernel.org>,
	"netdev\@vger.kernel.org" <netdev@...r.kernel.org>
Subject: Re: iwlwifi no authentication with AP - Re: pull request: wireless-next 2014-09-08

Emmanuel Grumbach <egrumbach@...il.com> writes:

> On Wed, Sep 10, 2014 at 8:01 AM, Oliver Hartkopp <socketcan@...tkopp.net> wrote:
>> On 10.09.2014 00:07, Vadim Kochan wrote:
>>> I have the same issue with iwlwifi.
>>
>> I tried an old zd1211 wireless USB stick to check if this problem is 80211
>> related. But the USB stick works fine (I'm using it right now).
>> So its definitely looks like an iwlwifi issue.
>>
>>> iwlwifi 0000:02:00.0: fail to flush all tx fifo queues Q 0
>>
>> Wasn't there any change in the iwlwifi tx path recently??
>
> Can you please try the patch attached? It works for me.

Upgraded to latest wireless-testing and iwldvm was broken. This patch
fixed it for me as well.

Could we have the fix in the wireless tree ASAP? Not really fun to find
out that the driver is completely broken.

-- 
Kalle Valo
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists