lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 23 Oct 2014 19:30:53 +0200 (CEST)
From:	Fabian Frederick <fabf@...net.be>
To:	Marcel Holtmann <marcel@...tmann.org>
Cc:	"Gustavo F. Padovan" <gustavo@...ovan.org>,
	Network Development <netdev@...r.kernel.org>,
	linux-kernel <linux-kernel@...r.kernel.org>,
	"David S. Miller" <davem@...emloft.net>,
	BlueZ development <linux-bluetooth@...r.kernel.org>,
	Johan Hedberg <johan.hedberg@...il.com>
Subject: Re: [PATCH 1/1 net-next] Bluetooth: fix shadow warning in
 hci_disconnect()



> On 23 October 2014 at 18:29 Marcel Holtmann <marcel@...tmann.org> wrote:
>
>
> Hi Fabian,
>
> > use cpr for hci_cp_read_clock_offset instead of cp
> > (already defined above).
> >
> > Signed-off-by: Fabian Frederick <fabf@...net.be>
> > ---
> > net/bluetooth/hci_conn.c | 6 +++---
> > 1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c
> > index b9517bd..6151e09 100644
> > --- a/net/bluetooth/hci_conn.c
> > +++ b/net/bluetooth/hci_conn.c
> > @@ -141,10 +141,10 @@ int hci_disconnect(struct hci_conn *conn, __u8 reason)
> >      */
> >     if (conn->type == ACL_LINK && conn->role == HCI_ROLE_MASTER) {
> >             struct hci_dev *hdev = conn->hdev;
> > -           struct hci_cp_read_clock_offset cp;
> > +           struct hci_cp_read_clock_offset cpr;
> >
> > -           cp.handle = cpu_to_le16(conn->handle);
> > -           hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cp), &cp);
> > +           cpr.handle = cpu_to_le16(conn->handle);
> > +           hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cpr), &cpr);
>
> valid change, but I do not like cpr as variable name. We need to come up with
> a better one. There are other places in the code where we had the same thing.
> Please have a look there.
>
> Regards
>
> Marcel
>

Hi Marcel,

  Maybe read_cp (like commit c1f23a2bfc89 with struct hci_cp_auth_requested
auth_cp) ?

Regards,
Fabian
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ