[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1415123796-8093-1-git-send-email-xiyou.wangcong@gmail.com>
Date: Tue, 4 Nov 2014 09:56:23 -0800
From: Cong Wang <xiyou.wangcong@...il.com>
To: netdev@...r.kernel.org
Subject: [PATCH 00/13] net_sched: misc cleanups and improvements
Minor code cleanups for TC qdiscs and filters, each patch has
more details.
Cong Wang (13):
net_sched: refactor out tcf_exts
net_sched: introduce qdisc_peek() helper function
net_sched: rename ->gso_skb to ->dequeued_skb
net_sched: rename qdisc_drop() to qdisc_drop_skb()
net_sched: introduce qdisc_drop() helper function
net_sched: move some qdisc flag into qdisc ops
net_sched: move TCQ_F_MQROOT into qdisc ops
net_sched: use a flag to indicate fifo qdiscs instead of the name
net_sched: redefine qdisc_create_dflt()
net_sched: forbid setting default qdisc to inappropriate ones
net_sched: remove hashmask from Qdisc_class_hash
net_sched: remove useless qdisc_stab_lock
net_sched: return NULL instead of ERR_PTR for qdisc_alloc()
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists