[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CA+55aFxZ9dhB074p3OAQLyQ53TuRjVOo33h6OOda1soh-9xxnQ@mail.gmail.com>
Date: Mon, 17 Nov 2014 12:52:17 -0800
From: Linus Torvalds <torvalds@...ux-foundation.org>
To: Alexander Duyck <alexander.h.duyck@...hat.com>
Cc: "linux-arch@...r.kernel.org" <linux-arch@...r.kernel.org>,
Network Development <netdev@...r.kernel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Mathieu Desnoyers <mathieu.desnoyers@...ymtl.ca>,
Peter Zijlstra <peterz@...radead.org>,
Benjamin Herrenschmidt <benh@...nel.crashing.org>,
Heiko Carstens <heiko.carstens@...ibm.com>,
Ingo Molnar <mingo@...nel.org>,
Michael Neuling <mikey@...ling.org>,
Russell King - ARM Linux <linux@....linux.org.uk>,
donald.c.skidmore@...el.com, matthew.vick@...el.com,
Geert Uytterhoeven <geert@...ux-m68k.org>,
Jeff Kirsher <jeffrey.t.kirsher@...el.com>,
Francois Romieu <romieu@...zoreil.com>,
Paul McKenney <paulmck@...ux.vnet.ibm.com>,
nic_swsd@...ltek.com, Will Deacon <will.deacon@....com>,
Michael Ellerman <michael@...erman.id.au>,
Tony Luck <tony.luck@...el.com>,
Oleg Nesterov <oleg@...hat.com>,
Martin Schwidefsky <schwidefsky@...ibm.com>,
Frédéric Weisbecker <fweisbec@...il.com>,
David Miller <davem@...emloft.net>
Subject: Re: [PATCH 2/4] arch: Add lightweight memory barriers fast_rmb() and fast_wmb()
On Mon, Nov 17, 2014 at 9:18 AM, Alexander Duyck
<alexander.h.duyck@...hat.com> wrote:
> There are a number of situations where the mandatory barriers rmb() and
> wmb() are used to order memory/memory operations in the device drivers
> and those barriers are much heavier than they actually need to be.
Ugh. I absolutely despise the name.
It's not "fast". It's just limited. It's the same as "smp_*mb()", in
that it works on cacheable memory, but it actually stays around even
for non-SMP builds.
So I think the name is actively misleading.
Naming should be about what it does, not about some kind of PR thing
that confuses people into thinking it's "better".
Maybe "dma_*mb()" would be acceptable, and ends up having the same
naming convention as "smb_*mb()", and explains what it's about.
And yes, in the same spirit, it would probably be good to try to
eventually get rid of the plain "*mb()" functions, and perhaps call
them "mmio_*mb()" to clarify that they are about ordering memory wrt
mmio.
Hmm?
Linus
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists