[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20141203094224.GB9487@redhat.com>
Date: Wed, 3 Dec 2014 11:42:24 +0200
From: "Michael S. Tsirkin" <mst@...hat.com>
To: Pankaj Gupta <pagupta@...hat.com>
Cc: linux-kernel@...r.kernel.org, netdev@...r.kernel.org,
davem@...emloft.net, jasowang@...hat.com, dgibson@...hat.com,
vfalico@...il.com, edumazet@...gle.com, vyasevic@...hat.com,
hkchu@...gle.com, wuzhy@...ux.vnet.ibm.com, xemul@...allels.com,
therbert@...gle.com, bhutchings@...arflare.com, xii@...gle.com,
stephen@...workplumber.org, jiri@...nulli.us,
sergei.shtylyov@...entembedded.com
Subject: Re: [PATCH v3 net-next 1/2] net: allow large number of rx queues
On Wed, Dec 03, 2014 at 12:49:36PM +0530, Pankaj Gupta wrote:
> netif_alloc_rx_queues() uses kcalloc() to allocate memory
> for "struct netdev_queue *_rx" array.
> If we are doing large rx queue allocation kcalloc() might
> fail, so this patch does a fallback to vzalloc().
> Similar implementation is done for tx queue allocation in
> netif_alloc_netdev_queues().
>
> We avoid failure of high order memory allocation
> with the help of vzalloc(), this allows us to do large
> rx and tx queue allocation which in turn helps us to
> increase the number of queues in tun.
>
> As vmalloc() adds overhead on a critical network path,
> __GFP_REPEAT flag is used with kzalloc() to do this fallback
> only when really needed.
>
> Signed-off-by: Pankaj Gupta <pagupta@...hat.com>
> Reviewed-by: Michael S. Tsirkin <mst@...hat.com>
> Reviewed-by: David Gibson <dgibson@...hat.com>
> ---
> net/core/dev.c | 19 +++++++++++++------
> 1 file changed, 13 insertions(+), 6 deletions(-)
>
> diff --git a/net/core/dev.c b/net/core/dev.c
> index e916ba8..abe9560 100644
> --- a/net/core/dev.c
> +++ b/net/core/dev.c
> @@ -6059,17 +6059,25 @@ void netif_stacked_transfer_operstate(const struct net_device *rootdev,
> EXPORT_SYMBOL(netif_stacked_transfer_operstate);
>
> #ifdef CONFIG_SYSFS
> +static void netif_free_rx_queues(struct net_device *dev)
> +{
> + kvfree(dev->_rx);
> +}
> +
I would just open-code this.
> static int netif_alloc_rx_queues(struct net_device *dev)
> {
> unsigned int i, count = dev->num_rx_queues;
> struct netdev_rx_queue *rx;
> + size_t sz = count * sizeof(*rx);
>
> BUG_ON(count < 1);
>
> - rx = kcalloc(count, sizeof(struct netdev_rx_queue), GFP_KERNEL);
> - if (!rx)
> - return -ENOMEM;
> -
> + rx = kzalloc(sz, GFP_KERNEL | __GFP_NOWARN | __GFP_REPEAT);
> + if (!rx) {
> + rx = vzalloc(sz);
> + if (!rx)
> + return -ENOMEM;
> + }
> dev->_rx = rx;
>
> for (i = 0; i < count; i++)
> @@ -6698,9 +6706,8 @@ void free_netdev(struct net_device *dev)
>
> netif_free_tx_queues(dev);
> #ifdef CONFIG_SYSFS
> - kfree(dev->_rx);
> + netif_free_rx_queues(dev);
> #endif
> -
and I think it's nicer with the empty line.
> kfree(rcu_dereference_protected(dev->ingress_queue, 1));
>
> /* Flush device addresses */
> --
> 1.8.3.1
>
> --
> To unsubscribe from this list: send the line "unsubscribe netdev" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists