[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1419847788-25610-1-git-send-email-mrkiko.rs@gmail.com>
Date: Mon, 29 Dec 2014 11:09:42 +0100
From: Enrico Mioso <mrkiko.rs@...il.com>
To: netdev@...r.kernel.org
Cc: Enrico Mioso <mrkiko.rs@...il.com>
Subject: [RFC PATCH 0/6] cdc_ncm: some basic refactoring
Here is some work I did to move in the direction of refactoring the cdc_ncm
module, to allow for future further changes.
This is work in progress (WIP): and I know some changes are controversial. In
particular, the modification you can see related to cdc_ncm.h header file is
useless at this point. But actually it can be useful for learning from your
opinions: is this the right thing to do?
Thank in advance to anyone reviewing this code.
The final objective would be to have the driver accumulate frames as it does
now, but in a skb queue (sk_buff_head), and then generating the NCM frame
itself only when needed (queue full / flueshed).
I need assistance / help: the logic seems hard to follow for me (is it me or
is it little bit convoluted?).
Thank you for any help, waiting for your comments.
Note: please CC me as I am not subscribed to this list.
Enrico Mioso (6):
cdc_ncm: factor out skb allocation and finalizzing
cdc_ncm: be more precise in comments for cdc_ncm_prepare_skb_ncm16
cdc_ncm: add needed members to cdc_ncm_ctx for refactoring
cdc_ncm: update specs URL
cdc_ncm: fix typo
cdc_ncm: factor out NDP preparation and frame linking
drivers/net/usb/cdc_ncm.c | 74 ++++++++++++++++++++++++++++++++-------------
include/linux/usb/cdc_ncm.h | 1 +
2 files changed, 54 insertions(+), 21 deletions(-)
--
2.2.1
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists