[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150220105405.GC7895@mwanda>
Date: Fri, 20 Feb 2015 13:54:05 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: "David S. Miller" <davem@...emloft.net>
Cc: Ben Hutchings <ben@...adent.org.uk>,
Amir Vadai <amirv@...lanox.com>,
Eric Dumazet <edumazet@...gle.com>,
Venkata Duvvuru <VenkatKumar.Duvvuru@...lex.Com>,
Ed Swierk <eswierk@...portsystems.com>,
Jiri Pirko <jiri@...nulli.us>,
Govindarajulu Varadarajan <_govind@....com>,
Eyal Perry <eyalpe@...lanox.com>, netdev@...r.kernel.org,
kernel-janitors@...r.kernel.org
Subject: [patch] ethtool: use "ops" name consistenty in ethtool_set_rxfh()
"dev->ethtool_ops" and "ops" are the same, but we should use "ops"
everywhere to be consistent.
Signed-off-by: Dan Carpenter <dan.carpenter@...cle.com>
diff --git a/net/core/ethtool.c b/net/core/ethtool.c
index 91f74f3..eb0c3ac 100644
--- a/net/core/ethtool.c
+++ b/net/core/ethtool.c
@@ -789,7 +789,7 @@ static noinline_for_stack int ethtool_set_rxfh(struct net_device *dev,
if (ops->get_rxfh_indir_size)
dev_indir_size = ops->get_rxfh_indir_size(dev);
if (ops->get_rxfh_key_size)
- dev_key_size = dev->ethtool_ops->get_rxfh_key_size(dev);
+ dev_key_size = ops->get_rxfh_key_size(dev);
if (copy_from_user(&rxfh, useraddr, sizeof(rxfh)))
return -EFAULT;
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists