lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20150225194234.GA3021@angus-think.lan>
Date:	Wed, 25 Feb 2015 21:42:34 +0200
From:	Vadim Kochan <vadim4j@...il.com>
To:	Jiri Pirko <jiri@...nulli.us>
Cc:	Vadim Kochan <vadim4j@...il.com>, stephen@...workplumber.org,
	netdev@...r.kernel.org
Subject: Re: [PATCH iproute2] lib: Replace 16384 netlink buf by macro

On Wed, Feb 25, 2015 at 05:46:55PM +0100, Jiri Pirko wrote:
> Wed, Feb 25, 2015 at 05:04:17PM CET, vadim4j@...il.com wrote:
> >From: Vadim Kochan <vadim4j@...il.com>
> >
> >Replaced hard coded 16384 sized netlink message buffer
> >by NL_BUF(x) macro.
> >
> >Buffer size can be overrided by -DNLBUF_SIZE.
> >
> >Signed-off-by: Vadim Kochan <vadim4j@...il.com>
> >---
> > include/libnetlink.h | 6 ++++++
> > ip/iplink.c          | 2 +-
> > lib/libnetlink.c     | 8 ++++----
> > misc/ss.c            | 2 +-
> > 4 files changed, 12 insertions(+), 6 deletions(-)
> >
> >diff --git a/include/libnetlink.h b/include/libnetlink.h
> >index 898275b..883f581 100644
> >--- a/include/libnetlink.h
> >+++ b/include/libnetlink.h
> >@@ -170,5 +170,11 @@ extern int rtnl_from_file(FILE *, rtnl_filter_t handler,
> >  * messages from dump file */
> > #define NLMSG_TSTAMP	15
> > 
> >+#ifndef NLBUF_SIZE
> >+#define NLBUF_SIZE 16384
> >+#endif
> >+
> >+#define NL_BUF(b) char  b[NLBUF_SIZE]
> >+
> > #endif /* __LIBNETLINK_H__ */
> > 
> >diff --git a/ip/iplink.c b/ip/iplink.c
> >index 5893ee4..b9949a8 100644
> >--- a/ip/iplink.c
> >+++ b/ip/iplink.c
> >@@ -770,7 +770,7 @@ int iplink_get(unsigned int flags, char *name, __u32 filt_mask)
> > {
> > 	int len;
> > 	struct iplink_req req;
> >-	char answer[16384];
> >+	NL_BUF(answer);
> 
> Why to obfuscate this? "char answer[NLBUF_SIZE];" seems allright...
> 

Well, I thought that it would be easy to change the netlink buffer type
in the future, but may be you're right - "char answer[NLBUF_SIZE];" is
more readable anyway.

Thanks,
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ