[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20150316.000113.1803291537029624713.davem@davemloft.net>
Date: Mon, 16 Mar 2015 00:01:13 -0400 (EDT)
From: David Miller <davem@...emloft.net>
To: herbert@...dor.apana.org.au
Cc: tgraf@...g.ch, netdev@...r.kernel.org, eric.dumazet@...il.com
Subject: Re: [v1 PATCH 0/14] rhashtable: Kill shift/Key netlink
namespace/Merge jhash
From: Herbert Xu <herbert@...dor.apana.org.au>
Date: Sun, 15 Mar 2015 21:43:06 +1100
> PS I'd love to kill the indirect call on the hash but I think
> you guys need something other than jhash for sockets. Presumably
> they are not exposed to untrusted parties. But I really wonder
> whether that is still the case given things like namespaces where
> even root may be untrusted.
In my opinion the biggest architectural fault of rhashtables is
these damn callbacks, look at the assembler for a simple hash
lookup, it's disgusting.
Two callbacks, _two_.
That also means the hash lookup can't be a leaf function, and we take
two mispredicted indirect calls as well. Not acceptable.
This is pure overhead from overengineering in my opinion and I'd much
rather have code duplication than this.
We should have rhashtable_lookup_compare() be a macro, for which the
caller provides the hash function and compare operation inline.
Otherwise when we convert things like inet_hashtables.c to rhashtable
it's going to be a regression that will definitely show up in
microbenchmarks.
So essentially I think the rhashtables interface to how the keys are
described to the user is inside out. rhashtable should just provide
the outer-framework, and the user should provide the minute details of
the key hashing and comparison in something that gets expanded inline.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists