[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1426596159.23897.61.camel@perches.com>
Date: Tue, 17 Mar 2015 05:42:39 -0700
From: Joe Perches <joe@...ches.com>
To: Nicholas Mc Guire <hofrat@...dl.org>
Cc: Brett Rudley <brudley@...adcom.com>,
Arend van Spriel <arend@...adcom.com>,
"Franky (Zhenhui) Lin" <frankyl@...adcom.com>,
Hante Meuleman <meuleman@...adcom.com>,
Kalle Valo <kvalo@...eaurora.org>,
"John W. Linville" <linville@...driver.com>,
Pieter-Paul Giesberts <pieterpg@...adcom.com>,
Daniel Kim <dekim@...adcom.com>,
Johannes Berg <johannes.berg@...el.com>,
linux-wireless@...r.kernel.org, brcm80211-dev-list@...adcom.com,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] brcmfmac: cfg80211: use msecs_to_jiffies for time
conversion
On Tue, 2015-03-17 at 08:06 -0400, Nicholas Mc Guire wrote:
> Converting milliseconds to jiffies by "val * HZ / 1000" is technically
> OK but msecs_to_jiffies(val) is the cleaner solution and handles all
> corner cases correctly. This is a minor API consolidation only and
> should make things more readable.
Hi Nicholas
These API consolidation changes now always have a function
call when the compiler may have previously been able to
optimize out the "constant * HZ / 1000" calculation.
Perhaps the [um]secs_to_jiffies calls should be indirected
with yet another static inline with a __builtin_constant_p()
test so that the function calls can again be avoided when
possible.
(and a trivial style note)
> diff --git a/drivers/net/wireless/brcm80211/brcmfmac/cfg80211.c b/drivers/net/wireless/brcm80211/brcmfmac/cfg80211.c
[]
> @@ -1110,7 +1110,7 @@ brcmf_cfg80211_escan(struct wiphy *wiphy, struct brcmf_cfg80211_vif *vif,
>
> /* Arm scan timeout timer */
> mod_timer(&cfg->escan_timeout, jiffies +
> - WL_ESCAN_TIMER_INTERVAL_MS * HZ / 1000);
> + msecs_to_jiffies(WL_ESCAN_TIMER_INTERVAL_MS));
It may be nicer to keep the arithmetic on one line
mod_timer(&cfg->escan_timeout,
jiffies + msecs_to_jiffies(WL_ESCAN_TIMER_INTERVAL_MS));
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists