[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <55079FA1.3040604@gmail.com>
Date: Mon, 16 Mar 2015 21:29:37 -0600
From: David Ahern <dsahern@...il.com>
To: Jiri Pirko <jiri@...nulli.us>
CC: netdev@...r.kernel.org, Scott Feldman <sfeldma@...il.com>
Subject: Re: [PATCH 1/3] net: add support for phys_port_name
On 3/16/15 10:00 AM, Jiri Pirko wrote:
>> @@ -1159,6 +1168,8 @@ struct net_device_ops {
>> bool new_carrier);
>> int (*ndo_get_phys_port_id)(struct net_device *dev,
>> struct netdev_phys_item_id *ppid);
>> + int (*ndo_get_phys_port_name)(struct net_device *dev,
>> + struct netdev_phys_item_name *name);
>
> I think that we do not need the structure. Just pass "char *name" for buffer
> where to put the name and "size_t len" for len of the buffer. Have:
> #define PORT_NAME_MAX_LEN 32
> and have called to have "char name[PORT_NAME_MAX_LEN]"
>
> Also, given that this is related to switches, won't it make sense to
> push this into switchdev code?
BTW, in regards to the latter comment phys_port_name should stay with
phys_port_id which is currenly not a switchdev op.
David
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists