[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20150518.122105.520335575641904166.davem@davemloft.net>
Date: Mon, 18 May 2015 12:21:05 -0400 (EDT)
From: David Miller <davem@...emloft.net>
To: sshah@...arflare.com
Cc: netdev@...r.kernel.org, linux-net-drivers@...arflare.com
Subject: Re: [PATCH net-next 01/16] sfc: Add permissions to MCDI commands
From: Shradha Shah <sshah@...arflare.com>
Date: Mon, 18 May 2015 16:27:00 +0100
> @@ -637,6 +637,9 @@
> * Read multiple 32byte words from MC memory.
> */
> #define MC_CMD_READ32 0x1
> +#undef MC_CMD_0x1_PRIVILEGE_CTG
> +
> +#define MC_CMD_0x1_PRIVILEGE_CTG SRIOV_CTG_ADMIN
Please do not add unnecessary #undef statements like this.
It makes your code harder to read, and in particular harder to
audit for problems. Because you're making it look like you are
explicitly overriding a definition from somewhere else, so people
have to go grepping around to find out where that is only to find
out that no such place even exists.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists