[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1442995078-10491-1-git-send-email-jiri@resnulli.us>
Date: Wed, 23 Sep 2015 09:57:48 +0200
From: Jiri Pirko <jiri@...nulli.us>
To: netdev@...r.kernel.org
Cc: davem@...emloft.net, idosch@...lanox.com, eladr@...lanox.com,
sfeldma@...il.com, f.fainelli@...il.com, linux@...ck-us.net,
vivien.didelot@...oirfairelinux.com, rami.rosen@...el.com,
roopa@...ulusnetworks.com, pjonnala@...adcom.com, andrew@...n.ch,
gospo@...ulusnetworks.com
Subject: [patch net-next v2 00/10] switchdev: transaction item queue and cleanup
From: Jiri Pirko <jiri@...lanox.com>
Jiri Pirko (10):
switchdev: rename "trans" to "trans_ph".
switchdev: introduce transaction item queue for attr_set and obj_add
switchdev: move transaction phase enum under transaction structure
switchdev: add switchdev_trans_ph_prepare/commit helpers
rocker: push struct switchdev_trans down through rocker code
rocker: use switchdev transaction queue for allocated memory
switchdev: remove "NONE" transaction phase
switchdev: remove "ABORT" transaction phase
dsa: use prepare/commit switchdev transaction helpers
switchdev: reduce transaction phase enum down to a boolean
Documentation/networking/switchdev.txt | 19 ++
drivers/net/ethernet/rocker/rocker.c | 306 ++++++++++++++-------------------
include/net/switchdev.h | 40 +++--
net/dsa/slave.c | 31 ++--
net/switchdev/switchdev.c | 117 ++++++++++---
5 files changed, 287 insertions(+), 226 deletions(-)
--
1.9.3
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists